java教程

java.lang.UnsupportedClassVersionError 不能运行main方法

位置:首页 > java教程 > java技巧,2018-03-05 23:18
java.lang.UnsupportedClassVersionError 不能运行main方法问题主要是因为ide使用的jdk版本与jar要求的版本不符合。修改一下版本就可以了。

 观察一下报错截图:

java.lang.UnsupportedClassVersionError(图0)

  原来我的Eclipse的JDK是1.6的,但是jar包明确要求需要1.7的,当然会出错了!

  那么,如何改正呢?下载1.7版本的JDK就不说了。

  右键点击项目工程,Properties

java.lang.UnsupportedClassVersionError(图1)

  点击JRE library

java.lang.UnsupportedClassVersionError(图2)

  修改JDK版本

java.lang.UnsupportedClassVersionError(图3)

java.lang.UnsupportedClassVersionError(图4)

java.lang.UnsupportedClassVersionError(图5)

  最后编译成功!

java.lang.UnsupportedClassVersionError(图6)

TAGS:java.lang.UnsupportedClassVersionError

猜你喜欢

本月热门的内容

最近更新的内容

NewHot